Environment
Novell ZENworks Patch Management Server Web Interface
Situation
This information applies to:
PatchLink Update Agent 6.0
PatchLink Update Agent 6.1
PatchLink Update Agent 6.2
Error Message in the patchlink update agent.log
file
2006/03/06 13:34:01.0828,0,AgentEngineApp::startAgent: Agent:
DateTime::init: ::localtime: Bad date supplied.
SYMPTOMS
Agent has stopped in the control panel applet and will not restart
Agent has stopped in the control panel applet and will not restart
Agents offline
Bad date supplied error in agent log
CAUSE
The time for agent start time in HKLM\SOFTWARE\PATCHLINK.COM\GRAVITIX\AGENT\POLICY\ is set for 12:00 PM and the stop time is set for 12:00 AM
This is set in Hours of operations policy in the Options page,
Default tab or set from a custom policy
Resolution
The agents will not automatically start, check in and pick up
the new policy after the policy change, so modify the
following:
1. Change the start and stop time correctly in the defaults tab or custom policy.
2. In HKLM\SOFTWARE\PATCHLINK.COM\GRAVITIX\AGENT\POLICY\
Set the start time for 12:00 AM or any time other than 12:00
PM such as 1:00 PM As long as it is greater than 12:59 PM. There
seems to be a 59 min window that does not work within the 12:00
times any other exact 12 hr offset such as 3 to 3 works ok.
3. Restart the agent in the control panel applet.
4. Press Check Now in the control panel applet so the agents check in and get the new policy from the server.
4. Press Check Now in the control panel applet so the agents check in and get the new policy from the server.
You will not need to reboot the pc or server to get the agents
working again.