SUN Olson TZ data tzdata2005r or greater incompatibility

  • 3008665
  • 09-Mar-2007
  • 26-Apr-2012

Environment

Java SE v1.4.x

Situation

Sun Alert 102836 "Olson TZ Data (tzdata2005r or greater) Incompatibility Issues"
Sun as released a document to address a issue with Daylight Saving time for Java
  • JDK and JRE v1.4.2_12 and above
  • JDK and JRE 5.0u8 and above
  • JDK and JRE 6 and above
  • any instance of java that has been update by the TZUpdater tool.

This condition will be apparent under one of the following two circumstances:

A)The use of old 3-letter TZ IDs, limited to: "EST", "HST", "MST".

Or:

B)The parsing of date strings containing one of the following three TZ strings: "EDT", "HDT", or"MDT".

Resolution

All Novell products which rely on the Sun JRE need this update to avoid Daylight Saving Time issues.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.