NDPS print jobs being sent to the wrong physical printer

  • 3004104
  • 11-Jul-2006
  • 26-Apr-2012

Environment

Novell Netware 6.5 Support Pack 4
NDPS 4.0.4
Novell Client for Windows 4.91

Situation

Client submitted Ndps print jobs are being printed to the wrong physical printer.
Attempting to shut down Ndps Manager from the Server console also causes this process to hang on many printer
agents.

Cause :
Ndps database corruption.
An analysis of the ndps database exported to the .csv file revealed a control char in a printer definition line.

Resolution

Recreate the Ndps database using the .csv file & pagen :
1. Locate the PADBTXT.CSV file under Volume SYS (or depending where the Ndps Manager database has been
    created) SYS:NDPS/xxxxxxxx.PSM/PADBTXT.CSV
    Open the PADBTXT.CSV file in Wordpad, Notepad or any ASCII based text editor.
2. Read the Ndps printer definition line for line identifying any formatting issues, particularly where a control
     char is where it isn't supposed to be. Each line is a seperate definition, 1 per printer agent.
     Pay particular attention to a definition that erroronously continues on the next line.
     If unsure of formatting of any entries, cut & paste this printer definition out of the .csv file  ; printer
     agent can be created at any stage with the definition you have just saved.
3. Correct any formatting issues.
4. Save the file again in text format.

Use pagen as per TID 10092230 to recreate ndps database.