iPrint Cluster resource shows status of Comatose

  • 3003316
  • 29-Jun-2006
  • 27-Apr-2012

Environment

Novell iPrint for Linux Open Enterprise Server Support Pack 2
Novell Open Enterprise Server (Linux based)

Situation

After issuing the Cluster Online command:
      Cluster Online [name_of_resource]
          or
      Cluster Online MyiPrintSharedDisk

the shared disk hosting iPrint shows a status of Comatose (Cluster Status command)

Resolution

There are two known causes to this problem, and therefore two possible fixes:

Cause 1:  Shared File System is mounted while Cluster Resource is Offline.
If the iPrint cluster resource is brought offline (Cluster Offline [resource]) while a session is open and browsed into that portion of the File System (at the console, through Putty, or some other tool), then the resource will show a status of down.  However, the mount command will show that the resource is mounted.

For example, compare the results between the Cluster Status and mount commands.  Cluster Status will say Offline while the mount command will show it is mounted.  Issuing the Cluster Online [resource] command while in this state will result in the shared resource going Comatose.

Fix 1:
a.  Ensure no users are sitting within the shared file system. 
         - issue this command for all sessions sitting within the shared resource:  cd /
                 or
         - if you are not certain if a session is sitting within the shared file system, then restart the server
b.  umount /[path_to_shared_point]
c.  mount
        - Review the list of mounted file systems.  Verify that the shared resource is not listed.
d.  Cluster Status
        - confirm the status of the iPrint resource is Offline
e.  Cluster Online [name_of_resource]

Cause 2:
File System corruption.  Review the fsck man page for your resource's file system type.  Below shows examples of how to resolve this if you are running the Reiser FS.

Fix 2:
Unmount the file system
          umount [/file/system/mount-point]
                   or
          umount  [/dev/path-to-filesystem-device]

Running this command will inform you if corruption exists and provide a suggestion to repair it.
          reiserfsck --check /dev/[path/to/fsdevice]

An example of a suggestion that might be provided by the --check option is --fix-fixable.  For example:
          reiserfsck --fix-fixable /dev/[path/to/fsdevice]

Once the file system is repaired, online the cluster resource.
      Cluster Online [name_of_resource]