Environment
Novell NetWare 6.5
Novell NetWare 5.1
Btrieve 7.9
Btrieve 7.51
Novell NetWare 5.1
Btrieve 7.9
Btrieve 7.51
Situation
ERROR: "PRODUCTS.DAT could not be accessed"
ERROR: "SYS:SYSTEM\PRODUCTS.DAT file could not be accessed."
ERROR: "The operation aborted because the SYS:SYSTEM\PRODUCTS.DAT file could not be accessed."
"butil -stat sys:\system\products.dat" or "prodsync menu" still works.
ERROR: "SYS:SYSTEM\PRODUCTS.DAT file could not be accessed.
ERROR: "The operation aborted because the SYS:SYSTEM\PRODUCTS.DAT file could not be accessed.
"butil -stat sys:\system\products.dat" or "prodsync menu" still works.
Resolution
Copy NWCONFIG.NLM from the support pack or another server running
the same support pack to C:\NWSERVER, replacing the module that is
there.
Additional Information
Root Cause:
NWCONFIG.NLM replaces some of the btrieve functions when it loads, so corruption in NWCONFIG.NLM or the wrong version can cause this problem.
NWCONFIG.NLM replaces some of the btrieve functions when it loads, so corruption in NWCONFIG.NLM or the wrong version can cause this problem.