ZENworks Install of Novell Client 4.9 SP2 as "Secure System User" fails.

  • 10094891
  • NOVL99161
  • 05-Oct-2004
  • 05-Oct-2004

Archived Content: This information is no longer maintained and is provided 'as is' for your convenience.

Fact

Novell Client 4.9 SP2 for Windows NT/2000/XP

Symptom

ZENworks Install of Novell Client 4.9 SP2 as "Secure System User" fails.

ZENworks NT Impersonation

Note

"Unsecure System User" works.  The Client install works well with this method of deployment.

PLATFORM/CONFIGURATION:
NT4 SP6a

STEPS TO REPRODUCE:
Edit setupsp.inf and make the following changes
UpdateNetIdentity = NO
Reinstall = YES
DisplayInstallPrompts = NO
RebootOnCompletion = YES
PromptUserOnCompletion = NO
Create a zen application object make it point to unc path \\server\what\ever\setupsp.exe

This will install fine as an administrator user.
This will install fine as un-secure system user (You see the screen output)
This will FAIL to install correctly using secure system user

It fails on part 1 which is the file copy. The other sections nmas install, nici install complete successfully. To verify the installation failure, notice that the files in c:\windows\system32\netware do NOT get updated. Also, the version string on the top bar of the Novell Client may read "4.90.0.20040617" (or similar) instead of "4.9 SP2."

Cause

This problem is related to the way Microsoft handles the installation of a driver that is not signed in "non-interactive" mode. The Novell Client installation routine uses the Microsoft installer to complete the installation of the Client. As currently designed by Microsoft, it is not possible to install programs with unsigned drivers in non-interactive mode. See Microsoft Knowledge Base Article 840257.

Fix

Use "Unsecure System User" instead of "Secure System User."

Feedback service temporarily unavailable. For content questions or problems, please contact Support.