Error loading zfdamrservlet.war file in Tomcat 4.1.30 version with NW6.5SP2.

  • 10094790
  • NOVL99069
  • 28-Sep-2004
  • 16-Jul-2006

Archived Content: This information is no longer maintained and is provided 'as is' for your convenience.

Fact

Novell ZENworks 7 Desktop Management - ZfD7

Novell ZENworks 6.5 Desktop Management - ZfD6.5

Novell ZENworks for Desktops 4.0.1 - ZfD4.0.1

Novell Application Launcher (NAL)

Novell ZENworks Desktop Management

Tomcat 4.1.30

Novell NetWare 6.5

Novell NetWare 6.5 Support Pack 2

Symptom

Error loading zfdamrservlet.war file in Tomcat 4.1.30 version with NW6.5SP2.

Error:  "WebAppClassLoader:  validateJarFile(sys:\tomcat\4\webapps\zfdamrservlet\WEB-INF\lib\servlet.jar) - jar not loaded.  See Servlet Spec 2.3, section 9.7.2. Offending class:  javax/servlet/Servlet.class" in the logger screen on NW6.5.

Fix

For ZENworks 7, fixed in ZENworks 7 with SP1  Desktop Management, available at https://download.novell.com

For ZENworks 6.5, fixed in ZENworks 6.5 Desktop Management Support Pack 1.

For ZENworks for Desktops 4.0.1, fixed in IR7. 

Note

STEPS TO REPRODUCE:
1.  Install NW 6.5 SP2.
2.  Install ZENworks Desktop Management to your server. 
3.  Copy the zfdamrservlet.war file like it says in the documentation here: https://www.novell.com/documentation/zenworks65/dmadmin/data/ahi0m5j.html#ahi0m5j
4.  Do a "tomcat4 stop" command and look at the logger screen to make sure it goes down.
5.  Do a "tomcat4 start" command and look at the logger screen and you will see the error.

RESULTS: 
You cannot get this to load and get XML reporting to work with this version of tomcat.