Long bootup or login time after installing ZDM 6.5 agent

  • 10093451
  • NOVL97676
  • 30-Jun-2004
  • 09-May-2006

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Fact

Novell ZENworks for Desktops 6.5 - ZFD65

Novell ZENworks Management Agent 6.5

Symptom

Long bootup or login time after installing ZDM 6.5 agent

After installing the ZfD 6.5 Management Agent, the bootup time and/or login time is increased by 2 minutes or so.

ZENworks 6.5 Agent install to Dell GX260 w/ SQL apps causes IE/Ctrl Panel to hang.

Cause

The cause of the long delay is related to a new Novell architecture in the logon process.  Instead of the xtier agent being a system driver, it has been changed to be a service - started by the Windows Service Control Manager.  The NWGINA calls into the Xtier agent's service before logging a user in.  When the NWGINA makes a call to the Xtier agent, it must wait until that xtier agent's service is functional.  That service will be functional as soon as it is called by the Windows Service Control Manager.  Being at the mercy of the Windows Service Control Manager means that if another service fails to start, it could cause a delay before the Xtier agent's service is started.  If another service delays the Service Control Manager from starting the xtier agent (..system32\novell\XTAGENT.DLL and XTAGENT.EXE), then NWGINA is delayed for the same amount of time from being able to process the login.  This problem has been seen with several 3rd party applications/services such as VMWare, Sofos Anti-virus, MS Fax Service, and various SQL applications including Acuate, etc.

Fix

Fixed in Novell ZENworks Desktop Management 6.5 Support Pack 1 found at Novell Product Updates

Ensure the following Xtier service registry keys are set:

HKLM\System\CurrentControlSet\Services\XTAgent

<string> Group = Base

<dword> Start = 2

Workarounds: 
1. Identify and disable the conflicting service.  
2. Rename the XTAGENT.DLL.

Note

If you rename or remove XTAGENT.DLL, no ZENworks services (AWI, Policies, Inv. etc.) will be available on an Agent only workstation.