How to get SYS mounted with BACKOUT.TTS problems.

  • 10012089
  • 4.0.884064.2190734
  • 16-Jun-1999
  • 21-Feb-2003

Archived Content: This information is no longer maintained and is provided 'as is' for your convenience.

Goal

How to get SYS mounted with BACKOUT.TTS problems.

Fact

Novell NetWare 3.11 SFT III

        Novell NetWare 4.11 SFT III

Novell NetWare 4.11

Novell NetWare 3.2

Formerly KB 2910209

Symptom

Can't Mount SYS because of BACKOUT.TTS.

The SYS volume will not mount .

The SYS volume appears to take a long time to mount while scanning BACKOUT.TTS.

High utilization during initial SYS volume mount.  

High disk activity on server

Cause

The TTS backout file has filled the SYS volume.

The BACKOUT.TTS file is invalid.

The BACKOUT.TTS file is so large it will take an unacceptable amount of time to backout these incomplete transactions.

Fix

Novell Possible Fixes                                        
1.  <JUST WAIT>  Most likely the file is just large and will eventually backout.  For very large files, this can take hours.  Backout transaction files could have grown to hundreds of megabytes, appropriately or inappropriately, and can take 3-5 hours to backout.  
2.  <RUN LATEST VREPAIR> to fix or delete a corrupt BACKOUT.TTS.  
Make sure you are using the latest VREPAIR program., Go to https://support.novell.com/misc/patlst.htm and check the appropriate version of NetWare to see what the latest available VREPAIR version.
3.  Use RCONSOLE to transfer a Zero byte BACKOUT.TTS from the workstation to the server.  You must rename the SYS volume first. Use INSTALL.NLM which is on the C:\NWSERVER to rename the SYS volume before mounting the volume.  Then LOAD REMOTE and RSPX.   This does require you to have at least two servers in the environment.  One to obtain the rconsole list from. This option will work every time if you do it properly.
4.  <REMOVE THE VOLUME>, reinstall NetWare and restore data from tape.  NOTE: For 4.1x systems, any attribute that references the file system of this server will be lost, ie, directory maps, print queues, etc.  If you are unsure of the ramifications of this action, contact the NDS team.  

Possible Third Party Fixes
1. <Delete BACKOUT.TTS with NWCC>  
Use NetWork Command Center,  JCMD or Vcopy to delete the file.
Search the web for NWCC or JCMD.  You can try http://www.netwarefiles.com to find the program.
Explode and read the documentation for its use.

This product can be loaded from the C: drive with SYS mounted as another name.
Follow these procedures:
1.) Start the server -ns.
2.) Enter a file server name and internal ipx number if prompted
3.) Load the disk driver.  Then load install.  If install is not present on the C: partition, you will have to get the program and load if from floppy or from the partition
4.) Rename SYS to something like SYSTEMP.  NOTE: The original NW4.11 INSTALL.NLM has a bug preventing
SYS from being renamed back to SYS once the volume name has been changed.  If the current service
pack is not installed, then extract INSTALL.NLM and INSTALL.MSG and copy them to c:\NWSERVER (or wherever server.exe is located.)  Once the SYS volume can mount, these files should also be copied to:
sys:system/INSTALL.NLM
sys:system/NLS/4/INSTALL.MSG
5.) Run NWCC or Vcopy
6.) Change the attributes of SYS:\BACKOUT.TTS to read/write. Note: jcmd will not change the attributes correctly.
7.) Delete SYS:\BACKOUT.TTS
8.) Rename SYSTEMP back to SYS.
9.) Down the server and restart.

<Delete BACKOUT.TTS with On-Track>
Ontrack Data Recovery for NetWare     -   http://www.ontrack.com
Minneapolis: 800-872-2599 or 612-937-5161
Los Angeles: 714-641-0530
Washington D.C.: 703-821-2539
London: 441-372-741-999 or Toll free 0-800-24-39-96
Tokyo: 81-429-32-6365 or toll-free: 0120-413-374

Specific info on the product:
http://sparky.ontrack.com/netware.html
Ontrack Data Recovery for NetWare (Version 4.0)

Excerpt from the product description on Ontrack's web listing as of 7/12/96:
"NLM Data Recovery & Protection Utilities for NetWare: Ontrack Data Recovery for NetWare (ODRN) software ...lets you repair file system structures and copy data from a downed server volume to a secure location..."

NOTE: Use RCONSOLE, or JCMD.NLM, etc to view the file name before trying to delete BACKOUT.TTS.
NOTE: Novell does not recommend or endorse the purchase of specific 3rd party software products. This information is provided to help you find alternative support options.
NOTE: The BACKOUT.TTS file might also be named BACKOUT.000.  

Note

For NetWare 6, use the NWCONFIG.NLM from NetWare 5.x.  This can be obtained from a support pack or from the NWSERVER directory from a NW 5.x server.  This should only be used to rename SYS.  The recommended way to do this is to put NWCONFIG.NLM on a floppy and load it from there by typing LOAD A:/NWCONFIG.NLM at the system console.  This will give you the functionality to rename SYS.  This will only work if SYS is a traditional volume.  

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